Apple แจ้งนักพัฒนาต้องทำแอพให้รองรับ iOS 7 เต็มตัวก่อน 1 กุมภาพันธ์นี้

Apple แจ้งนักพัฒนาต้องทำแอพให้รองรับ iOS 7 เต็มตัวก่อน 1 กุมภาพันธ์นี้

สำหรับผู้ที่ใช้งาน iOS 7 อยู่ อาจจะเห็นได้ว่าบางแอพพลิเคชันที่มีให้ดาวน์โหลดบน App Store ยังคงใช้ดีไซน์หน้าตาแบบเดิมกับใน iOS 6 อยู่ รวมไปถึงบางแอพที่ใช้งานกับ iOS 7 ได้ไม่สมบูรณ์ แต่ภายในต้นปีหน้าปัญหาดังกล่าวกำลังจะหมดไปครับ

เมื่อ Apple ได้ประกาศให้นักพัฒนาแอพทราบทั้งผ่านทางเว็บไซต์ของตนและอีเมลที่ส่งหานักพัฒนาโดยตรง ใจความคือนับตั้งแต่หลังวันที่ 1 กุมภาพันธ์ปีหน้าเป็นต้นไป แอพที่จะส่งมาให้ตรวจสอบก่อนขึ้นวางขายใน App Store จำเป็นจะต้องพัฒนาขึ้นจากโปรแกรม Xcode เวอร์ชัน 5 ขึ้นไป และต้องรองรับ iOS 7 เท่านั้น โดยถือว่าเป็นไฟท์บังคับสำหรับนักพัฒนาแอพทุกๆ รายให้สร้างแอพตามไกด์ไลน์การพัฒนาแอพสำหรับ iOS 7 โดยคีย์หลัก 3 ประการที่ Apple ยกตัวอย่างก็เช่นแนวทางของอินเตอร์เฟส, ตัวอักษรที่อ่านง่าย เข้ากับดีไซน์โดยรวม และประการสุดท้ายก็คือต้องมีความตื้นลึกของอินเตอร์เฟส แบบที่ช่วยให้ผู้ใช้สามารถเข้าใจได้ง่ายว่าตรงจุดไหนทำอะไรได้บ้าง แม้ธีมหลักของระบบจะเป็นแบบ flat แบนราบก็ตาม

ซึ่งการบังคับครั้งนี้ น่าจะสร้างผลกระทบกับนักพัฒนาแอพมากพอสมควรเลย เพราะจำเป็นจะต้องออกแบบแอพใหม่แทบทั้งหมด แต่ก็นับเป็นประโยชน์สำหรับผู้ใช้งานทั่วไปครับ แต่ทั้งนี้ไม่แน่ใจว่าสำหรับเครื่องรุ่นเก่าที่ไม่สามารถใช้งาน iOS 7 ได้ จะมีผลเรื่องแอพในอนาคตหรือไม่ เนื่องจากในปัจจุบัน Apple จะเก็บแอพเวอร์ชันเก่าเอาไว้ให้สำหรับ iOS ที่เก่ากว่าเวอร์ชัน 7 อยู่ แต่ถ้าเริ่มบังคับให้แอพรองรับ iOS 7 ทั้งหมดเมื่อไร ก็ไม่รู้ว่าจะมีนักพัฒนารายใดยังตามอัพเดตแอพเวอร์ชันเก่าๆ ของตนให้อยู่หรือเปล่านะครับ แค่อัพเดตแอพเวอร์ชันใหม่ก็หมดแรงแล้ว

ที่มา: AppleInsider

0 Comments

แสดงความคิดเห็น

*ข้อความหรือข้อความที่แสดงในโฟส เกิดจากการตั้งกระทู้และถูกส่งขึ้นในระบบโดยอัตโนมัติจากสมาชิก ซึ่งทีมงานไม่ได้มีส่วนหรือพิสูจน์ข้อเท็จจริงใดๆ หากพบเห็นข้อความ หรือรูปภาพในกระทู้ที่ไม่เหมาะสม กรุณาแจ้งทีมงานเพื่อดำเนินการต่อไป..